Cloud services outage
Incident Report for TestLodge
Resolved
This incident has been resolved.
Posted almost 3 years ago. Oct 21, 2016 - 17:44 UTC
Monitoring
We're monitoring an incident with our DNS provider who has suffered a couple of outages today. The outages are effecting many of the leading cloud services and has meant all communication methods which we use such as twitter, our customer support portal and blog have also been affected.
Posted almost 3 years ago. Oct 21, 2016 - 17:00 UTC