Application availability
Incident Report for TestLodge
Resolved
The issue with one of our servers has now been resolved and the service is back to normal.
Posted about 1 year ago. Apr 19, 2018 - 06:28 UTC
Identified
We have identified an issue with one of our servers which is causing an outage to the application and hope to have the issue resolved shortly.
Posted about 1 year ago. Apr 19, 2018 - 06:19 UTC