Weekend Server Maintenance
Incident Report for TestLodge
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 21, 2018 - 09:36 UTC
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Jul 21, 2018 - 09:09 UTC
This incident affected: Web Application and API.